Jak wyłączyć edytor Gutenberg w WordPress? (i dlaczego trzeba)

Gutenberg to nowy, na razie opcjonalny edytor blokowy (nie mylić z wizualnym) do WordPress, który prawdopodobnie zastąpi obecny domyślny edytor w WordPress 5.0.

Do momentu jego oficjalnego wdrożenia jest on możliwy do instalacji w formie wtyczki, o czym przypomni nam jego reklama po pierwszym zalogowaniu do WordPressa lub aktualizacji że starszej wersji systemu.

Kiedy wyłączyć Gutenberg w WordPress?

Jednym z powodów, dla których będziesz chciał wyłączyć nowy edytor jest brak wsparcia Page Builderów takich jak Divi Builder, Visual Composer czy Elementor. Gutenberg wyłącza stary edytor, a więc korzystanie z nich będzie niemożliwe – poniżej przykład: Aktywny jednocześnie Visual Composer i Gutenberg.

Ponieważ twórcy nie wzięli pod uwagę, że nie każdy będzie miał możliwość i okazje wcześniej nauczyć się nowego edytora, poza wspominanym problemem pojawi się konieczność nauki użytkowników edytora blokowego lub jego wyłączenie, aby nie wprowadzać niepotrzebnego bałaganu.

Na końcu pozostawiam kompatybilność z dziesiątkami wtyczek, które będą działać tylko w starym edytorze np. popularnego rozszerzenia Shortcodes Ultimate, które od 7 miesięcy od zapowiedzi integracji nadal nie posiada jej wdrożonej do swojej wtyczki.

Jak wyłączyć edytor Gutenberg w WordPress?

Całe szczęście operacja wymaga dodania jednej linijki kodu do pliku functions.php motywu, najlepiej motywu potomnego lub wtyczki funkcyjnej.

add_filter( 'gutenberg_can_edit_post_type', '__return_false' );

Jak przywrócić klasyczny edytor wizualny po wyłączeniu Gutenberg’a?

Opisałem to dokładnie w tym artykule, w którym znajdziesz też film z instrukcją jak tego dokonać.

5/5 - (2 votes)
Powiązane tematy: WordPress
Strona w trakcie przebudowy :) Wróć niebawem, aby zobaczyć różnice.Na stronie mogą znajdować się linki polecające (affiliacyjne), które pozwalają utrzymać bloga. Zakup z mojego polecenia nie generuje dla Ciebie dodatkowych kosztów, a ja otrzymam prowizje od kwoty zapłaconej.

2 Replies to “Jak wyłączyć edytor Gutenberg w WordPress? (i dlaczego trzeba)”

  1. Janusz Kamiński

    Co ciekawe, że planowali przygotować WP 5.0 po wiośnie, potem po łacie, a teraz możliwe, że pojawi się aż w nowym roku. :)

  2. Paweł

    Nie do końca tak jest.
    Konkurencyjne buildery przynajmniej na tą chwilę radzą sobie z Gutenbergiem – taki DIVI w Gutku dodaje na samej górze kolorowy przycisk „Use The Divi Builder” + na starcie w treści blok informacyjny z dwoma przyciskami .
    Zaś Visual Composer, w swoich ustawieniach ma opcje wyłączenia Gutenberga …ale nawet przy włączonym, opcja edycji w VC jest dostępna na froncie, z poziomu paska administracyjnego, a także z poziomu kokpitu i listy stron/wpisów pod linkiem „Edit with WPBakery Page Builder”.
    Tak, że tutaj Gutenberg nie uniemożliwia (jeszcze) korzystania z innych builderów.

    Z ta kompatybilnością to tez tak nie do końca. Tutaj dopiero będzie bajzel, bo część rozwiązań pójdzie całkowicie w Gutenberga, część w niego zupełnie nie pójdzie, a część będzie próbowała okrakiem zapewniać przynajmniej czasowo wsparcie dla starego i nowego panelu – koszmar dla deweloperów i koszmar dla użytkowników.

    Z tym wyłączeniem Gutenberga to jest tak, że aktualnie można go wyłączyć – wszak jest tylko opcjonalna wtyczką.
    Po konsolidacji z core WP i zastąpieniu obecnego sytuacja ulegnie zmianie, wyłączenie nie spowoduje powrotu do tradycyjnego panelu którego już nie będzie, będzie nowy panel ze swoimi problemami, tylko z uproszczonym prawie TinyMCE zamiast bloczków. Czyli wyłączenie Gutenberga nie wyłączy go całkowicie, a tylko przełączy w tryb uproszczony.
    Powrót do tradycyjnego panelu zapewnić może wtyczka https://pl.wordpress.org/plugins/classic-editor/ -ona wypina wszystkie hooki Gutenberga i przywraca pliki tradycyjnego edytora (te, które niebawem znikną z instalki).
    Tylko to też nie jest idealne rozwiązanie, bo tu tak samo będzie problem z kompatybilnością, no i działać to tak może do czasu aż nie ruszą starego API ….a już pojawiały się głosy, że do tego dojdzie w nieodległej przyszłości.

    Tak więc jak ktoś chce się jak najdłużej przed Gutenbergiem bronić, to najlepszym wyjściem będzie pozostać na WP z gałęzi 4.9 – ta jeszcze długo będzie otrzymywała aktualizacje.
    Robiąc upgrade do wersji 5 jest się już skazanym na Gutenberga.

Przyłącz się do dyskusji

Bądź na bieżąco

Newsy i promocje - Marketing & WordPress

Maksymalnie trzy wiadomości w miesiącu dopasowane do Ciebie. Polityka Prywatności dostępna jest tutaj. Dla każdego subskrybenta prezent niespodzianka.

Dziękuję za zapis.

Niebawem przyjdzie do Ciebie mail powitalny. Twoja darmowa godzina na pracę w #WordPress została aktywowana.